$re = '/^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$/m';
$str = '1234-5678-9012-3412
5645-6789-7897-9879
87979879879798798
13156465487987
54654 231321 45654 464 3213 5464 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);