#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w*)\s(\w*)\n([^}])"
Local $sString = "HEADER1:{" & @CRLF & _
"key value" & @CRLF & _
"key value" & @CRLF & _
"..." & @CRLF & _
"HEADER2:{" & @CRLF & _
"key value" & @CRLF & _
"..." & @CRLF & _
"},key value" & @CRLF & _
"HEADER3:{" & @CRLF & _
"key value" & @CRLF & _
"HEADER4:{" & @CRLF & _
"key value" & @CRLF & _
"..." & @CRLF & _
"}" & @CRLF & _
"},key value" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = "$1:$2,$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)