import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w*)\\s(\\w*)\\n([^\\}])";
final String string = "HEADER1:{\n"
+ "key value\n"
+ "key value\n"
+ "...\n"
+ "HEADER2:{\n"
+ "key value\n"
+ "...\n"
+ "},key value\n"
+ "HEADER3:{\n"
+ "key value\n"
+ "HEADER4:{\n"
+ "key value\n"
+ "...\n"
+ "}\n"
+ "},key value\n"
+ "}\n";
final String subst = "$1:$2,$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}