package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)\s(\w*)\n([^}])`)
var str = `HEADER1:{
key value
key value
...
HEADER2:{
key value
...
},key value
HEADER3:{
key value
HEADER4:{
key value
...
}
},key value
}
`
var substitution = "$1:$2,$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}