use strict;
my $str = 'HEADER1:{
key value
key value
...
HEADER2:{
key value
...
},key value
HEADER3:{
key value
HEADER4:{
key value
...
}
},key value
}
';
my $regex = qr/(\w*)\s(\w*)\n([^}])/p;
my $subst = '$1:$2,$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";