using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)\s(\w*)\n([^}])";
string substitution = @"$1:$2,$3";
string input = @"HEADER1:{
key value
key value
...
HEADER2:{
key value
...
},key value
HEADER3:{
key value
HEADER4:{
key value
...
}
},key value
}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}