import Foundation
let pattern = #"(\w*)\s(\w*)\n([^}])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
HEADER1:{
key value
key value
...
HEADER2:{
key value
...
},key value
HEADER3:{
key value
HEADER4:{
key value
...
}
},key value
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:$2,$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)