$re = '/(\w*)\s(\w*)\n([^}])/';
$str = 'HEADER1:{
key value
key value
...
HEADER2:{
key value
...
},key value
HEADER3:{
key value
HEADER4:{
key value
...
}
},key value
}
';
$subst = "$1:$2,$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;