# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/product:\s+"(.+?)"//gm;t' <<< "{
name: \"something\"
product: \"ABC-123\"
}"