package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)product:\s+"(.+?)"`)
var str = `{
name: "something"
product: "ABC-123"
}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}