import re
regex = re.compile(r"product:\s+\"(.+?)\"", flags=re.MULTILINE)
test_str = ("{\n"
" name: \"something\"\n"
" product: \"ABC-123\"\n"
"}")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)