using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product:\s+""(.+?)""";
string substitution = @"";
string input = @"{
name: ""something""
product: ""ABC-123""
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}