$re = '/product:\s+"(.+?)"/m';
$str = '{
name: "something"
product: "ABC-123"
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;