use strict;
my $str = '{
name: "something"
product: "ABC-123"
}';
my $regex = qr/product:\s+"(.+?)"/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";