#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)product:\s+"(.+?)""
Local $sString = "{" & @CRLF & _
" name: "something"" & @CRLF & _
" product: "ABC-123"" & @CRLF & _
"}"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)