re = /product:\s+"(.+?)"/m
str = '{
name: "something"
product: "ABC-123"
}'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result