# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^~]+~\s*|\s*!r\b.*//gm;t' <<< "a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z"