package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^~]+~\s*|\s*!r\b.*`)
var str = `a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}