#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^~]+~\s*|\s*!r\b.*"
Local $sString = "a ~ b c d*e !r x" & @CRLF & _
"a ~ b c" & @CRLF & _
"a ~ b c d1 !r y" & @CRLF & _
"a ~ b c D !r z" & @CRLF & _
"a~b c d*e!r z"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)