using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^~]+~\s*|\s*!r\b.*";
string substitution = @"";
string input = @"a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}