re = /^[^~]+~\s*|\s*!r\b.*/m
str = 'a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result