// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^~]+~\s*|\s*!r\b.*").unwrap();
let string = "a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}