import Foundation
let pattern = #"^[^~]+~\s*|\s*!r\b.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y
a ~ b c D !r z
a~b c d*e!r z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)