#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(http:[a-z\d_./]*|\G(?!\A)) ([a-z\d_./]+)"
Local $sString = "Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы " & @CRLF & _
"в остальном тексте? http: //en. website. ru/ все ссылки с http " & @CRLF & _
"содержащие пробелы необходимо автоматически преобразовать в цельные ссылки " & @CRLF & _
"без пробелов http://en.website. ru/ " & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)