# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http:[a-z\d_./]*|\G(?!\A)) ([a-z\d_./]+)"
test_str = ("Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы \n"
"в остальном тексте? http: //en. website. ru/ все ссылки с http \n"
"содержащие пробелы необходимо автоматически преобразовать в цельные ссылки \n"
"без пробелов http://en.website. ru/ \n")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.