const regex = new RegExp('(http:[a-z\\d_./]*|\\G(?!\\A)) ([a-z\\d_./]+)', 'gu')
const str = `Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы
в остальном тексте? http: //en. website. ru/ все ссылки с http
содержащие пробелы необходимо автоматически преобразовать в цельные ссылки
без пробелов http://en.website. ru/
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);