re = /(http:[a-z\d_.\/]*|\G(?!\A)) ([a-z\d_.\/]+)/
str = 'Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы
в остальном тексте? http: //en. website. ru/ все ссылки с http
содержащие пробелы необходимо автоматически преобразовать в цельные ссылки
без пробелов http://en.website. ru/
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result