use strict;
my $str = 'Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы
в остальном тексте? http: //en. website. ru/ все ссылки с http
содержащие пробелы необходимо автоматически преобразовать в цельные ссылки
без пробелов http://en.website. ru/
';
my $regex = qr~(http:[a-z\d_./]*|\G(?!\A)) ([a-z\d_./]+)~up;
my $subst = '$1$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";