import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:[a-z\\d_./]*|\\G(?!\\A)) ([a-z\\d_./]+)";
final String string = "Как убрать пробелы только в ссылках http: //en. website. ru/ не затронув пробелы \n"
+ "в остальном тексте? http: //en. website. ru/ все ссылки с http \n"
+ "содержащие пробелы необходимо автоматически преобразовать в цельные ссылки \n"
+ "без пробелов http://en.website. ru/ \n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}