import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)\\n(.+)\\n(.+)(\\n|$)";
final String string = "John Stave, Elon Mask\n"
+ "Amazon Inc\n"
+ "Michigan, Mi.\n\n"
+ "EAAlon MasBBk\n"
+ "Facebook Inc\n"
+ "New York, Ny.";
final String subst = "$1, $2, $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}