import Foundation
let pattern = #"(.+)\n(.+)\n(.+)(\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
John Stave, Elon Mask
Amazon Inc
Michigan, Mi.
EAAlon MasBBk
Facebook Inc
New York, Ny.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1, $2, $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)