re = /(.+)\n(.+)\n(.+)(\n|$)/m
str = 'John Stave, Elon Mask
Amazon Inc
Michigan, Mi.
EAAlon MasBBk
Facebook Inc
New York, Ny.'
subst = '$1, $2, $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result