const regex = /(.+)\n(.+)\n(.+)(\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)\\n(.+)\\n(.+)(\\n|$)', 'gm')
const str = `John Stave, Elon Mask
Amazon Inc
Michigan, Mi.
EAAlon MasBBk
Facebook Inc
New York, Ny.`;
const subst = `$1, $2, $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);