import re
regex = re.compile(r"(.+)\n(.+)\n(.+)(\n|$)", flags=re.MULTILINE)
test_str = ("John Stave, Elon Mask\n"
"Amazon Inc\n"
"Michigan, Mi.\n\n"
"EAAlon MasBBk\n"
"Facebook Inc\n"
"New York, Ny.")
subst = "$1, $2, $3"
result = regex.sub(subst, test_str)
if result:
print(result)