# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/\d+(?=\/|$)/\/*/gm;t' <<< "http://some_url.com/api/v1/1/2/3/4"