#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/\d+(?=/|$)"
Local $sString = "http://some_url.com/api/v1/1/2/3/4"
Local $sSubst = "/*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)