const regex = new RegExp('/\\d+(?=/|$)', 'gm')
const str = `http://some_url.com/api/v1/1/2/3/4`;
const subst = `/*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);