import re
regex = re.compile(r"/\d+(?=/|$)", flags=re.MULTILINE)
test_str = "http://some_url.com/api/v1/1/2/3/4"
subst = "/*"
result = regex.sub(subst, test_str)
if result:
print(result)