use strict;
my $str = 'http://some_url.com/api/v1/1/2/3/4';
my $regex = qr//\d+(?=/|$)/mp;
my $subst = '/*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";