import Foundation
let pattern = #"/\d+(?=/|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://some_url.com/api/v1/1/2/3/4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)