using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\d+(?=/|$)";
string substitution = @"/*";
string input = @"http://some_url.com/api/v1/1/2/3/4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}