re = /\/\d+(?=\/|$)/m
str = 'http://some_url.com/api/v1/1/2/3/4'
subst = '/*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result