const regex = /^(\d{5})(\d{7})(\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{5})(\\d{7})(\\d+)?$', 'gm')
const str = `111112222222
1111122222223`;
const subst = `$1-$2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);