import re
regex = re.compile(r"^(\d{5})(\d{7})(\d+)?$", flags=re.MULTILINE)
test_str = ("111112222222\n"
"1111122222223")
subst = "$1-$2-$3"
result = regex.sub(subst, test_str)
if result:
print(result)