use strict;
my $str = '111112222222
1111122222223';
my $regex = qr/^(\d{5})(\d{7})(\d+)?$/mp;
my $subst = '$1-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";