$re = '/^(\d{5})(\d{7})(\d+)?$/m';
$str = '111112222222
1111122222223';
$subst = "$1-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;