#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*"
Local $sString = "bucket/123/CODE_13-Sep-2015.txt" & @CRLF & _
"bucket/123/CODE_14-Sep-2015.txt" & @CRLF & _
"bucket/123/CODE_15-Sep-2015.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")