const regex = new RegExp('[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*', 'g')
const str = `bucket/123/CODE_13-Sep-2015.txt
bucket/123/CODE_14-Sep-2015.txt
bucket/123/CODE_15-Sep-2015.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}