import Foundation
let pattern = #"[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bucket/123/CODE_13-Sep-2015.txt
bucket/123/CODE_14-Sep-2015.txt
bucket/123/CODE_15-Sep-2015.txt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)