$re = '/[0-9]+/[A-Za-z0-9]+_((?=14-Sep-2015)).*/';
$str = 'bucket/123/CODE_13-Sep-2015.txt
bucket/123/CODE_14-Sep-2015.txt
bucket/123/CODE_15-Sep-2015.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);